[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


re:  'Eliminate the distinction between types "for declaration" and "for 

In the initial proposal, I thought it was clear from the context that 
this applied only to ARRAY type specifiers (and the later added COMPLEX 
specifiers); but if someone was confused about it, it wouldn't hurt to 
make it explicit.   

re: Stylisticly, this can be accomplished quickly if a bit awkwardly, by saying
    "The proposal is written using the following two functions, although these
    functions are not added to the standard." [UPGRADE-ARRAY-ELEMENT-TYPE ...]

The whole point of proposing these two functions is the acknowledgement that
every implementation must have them under one name or the other.  So why
not use the same name, so that  user code can access them?   The alternative
of a portable definition is not functinoally equivalent, since it conses.

-- JonL --