[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I happen not to like the name WITHIN-PACKAGE.

All of the other package operations are verbs. USE-xxx, MAKE-xxx,
EXPORT-xxx, etc. IN-PACKAGE has always been a glaring exception,
perhaps deliberately due to its dual role, perhaps due to oversight.
Anyway, I would just as soon see this use a verb, too.

Also, if IN-PACKAGE is retained for compatibility, I predict that
people will confuse it with WITHIN-PACKAGE often enough to be
an annoyance. I think that if we can conveniently avoid that 
gratuitous confusion, we should do so.

I suggest the name SELECT-PACKAGE.