[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


This proposal seems like a step in the right direction but I'm not 
entirely happy with it.

I'm speaking for myself here, and not the compiler committee, but I
think an alternate approach to this issue would simplify our work a
lot.  I would prefer to see the definition of IN-PACKAGE left alone,
the magic compiletime behavior of *all* of the random package
functions removed, and a new macro introduced to do what this proposal
wants IN-PACKAGE to do.  The reason for making it a macro instead of a
function is so that it can expand into an EVAL-WHEN to get the right
compiletime behavior instead of requiring the compiler to treat just
this one function specially.  The main problem I'm having is thinking
of what it should be called (since DEFPACKAGE is already being used
for another purpose).

I'm willing to do the writeup if you cleanup people who have been
handling the issue agree this is the right direction to proceed.  Let
me know.