[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

short form of define-method-combination

I am not enthusiastic about this proposal.  I have always liked having
the qualifier in the defmethod form explicitly, because it enhances
readability.  I think it's hard to understand what a method is doing if
you don't know how that method is going to be combined.  Having the
qualifier there reminds you what kind of combination is going to be

In order to eliminate the problem of having two separate methods that do
the same thing, I would rather make use of the qualifier be required
than forbidden.

I realize that this does not solve the problem of inventing symbols.
However, I think the benefit in readability outweighs this consideration.