[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using * in names

I must agree with Dick Waters and others, that code should use
*CATCH/*THROW from now on, but the old names CATCH and THROW
should not go away or be recycled, and *CATCH/*THROW also should not
go away.
But to prevent such glitches in the future, I have a suggestion:
when a feature is first implemented (say a function GLOTZ),
it should from the outset be called *GLOTZ.  Then when someone
eventually points out what a loser it is, one can invent the
better version and call that one just plain GLOTZ.  If *GLOTZ
turns out to be okay, then after two years the name GLOTZ can
be phased in as a synonym for *GLOTZ.