[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

substrings (sigh)

You're right - my proposed SUBSTRING-FROM-END was misconceived, and
couldn't do what you wanted it to.  Hmm.  But I still oppose the idea of
negative counts, for the reasons cited by Deutsch: loss of clarity, loss
of error-checking, and loss of efficiency.  So I still want to go with
two different names.  Actually, something involving the words TAKE and
DROP might be nice... I'll think about it... until something good comes
up, I'll go status quo, and omit from-end versions from the spec,
leaving name & functionality up in the air...