[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: On sequences

Perhaps  at  this  point  you  should  consider  including |SORT in your
collection of generic ops that  apply  to  sequences.   Also,  I think that
|SIZE would be better than |LENGTH; "length" makes sense only for sequences,
but "size" is appropriate for lots of objects which are aggregrates of other
objects, such as sets, bags, etc.; hence it is a better "generic" operation.