[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[no subject]

From:     DLW@MIT-AI
Date: Wed, 18 May 78 06:03:18 GMT
Original-Date: 05/18/78 02:03:18 EDT
    To: (BUG LISP) at MIT-AI
    Let me add my voice to the crowd:
    should define a macro called "FEXPR", rather than vice versa.  There
    are several reasons for this.  One is that the @ program and EMACS
    think of (DEFUN xxx ...) as the definition of xxx.
    	I was under the impression that everyone agreed to this change.
    How about it?
After a discussion with JONL, and consideration of my own feelings on the
matter, we have decided to change the 'LAST MOST FINAL' definition of the
hairy defun feature.  The current definiton will be:
(defun <spec> [<flag>] <bvl-or-lexpr-flag> <body>)

Where <spec> is what to defun (can be a list if putting on an arbitrary
property).  <flag> is optional and is the type of function (fexpr, expr,
macro).  Note the change is that the first thing is ALWAYS the spec.
We are not sure when we will release this...