[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
- To: RWK at MIT-MC, ALAN at MIT-MC, (BUG LISP) at MIT-MC
- Subject: DISPLACE
- From: KMP at MIT-MC (Kent M. Pitman)
- Date: Tue, 30 Dec 80 02:01:00 GMT
- Cc: GJC at MIT-MC
- Original-date: 29 DEC 1980 2101-EST
I recognize that there exists code which will be screwed by not checking
purity and that there may also exist code which will be screwed up by the
check. ALAN: are you doing explicit displace calls or calling defmacro
with displace optin requested?
Is the functin REPLACE in use all over? Probably, huh? That would be a fine
name for the functin I want. I would still prefer
that operators which operate in a code-oriented manner rather than
a list-oriented manner be named to identify that. Eg, a code-subst functin
would be more usful than a subst functin like we have right now but throwing
out the simple semantics for the simple operator is unfair. .. i don't know.
many hard decisions. i guess we should do something that will move toward
compatibility with lispm. how heavily is displace used on lispm. ..?
can we postpone doing anything drastic until i return to a terminal where i
can compose my thoughts reasonably ? tnx