[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

:SELECT-METHOD function spec.

The new function spec sounds like a good idea.  It has all the same
advantages that getting rid of flavor method symbols had.  I'd prefer to
see a new kind of spec (:select-method) rather than see :method
extended.  Flavors and select-methods really are two different things;
if I were debugging and ran into a spec, I'd like it to be apparent
which kind of thing it is a spec for.  The idea of function specs is to
have one kind of spec for each new place that functions get stored;
these are two different places and deserve two different specs.  There
is no reason to start overloading :method with more than one meaning
and introduce possible ambiguity problems.  Having a separate one seems
simpler and clearer to me than combining them.