[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: Issue "Eliminate forced consing" re-visited
- To: Scott.Fahlman@B.GP.CS.CMU.EDU
- Subject: Re: Issue "Eliminate forced consing" re-visited
- From: masinter.PA@Xerox.COM
- Date: 23 Aug 88 23:11:02 PDT
- Cc: trwrb!smpvax1!jrg@ucbvax.Berkeley.EDU, email@example.com.EDU
- In-reply-to: Scott.Fahlman@B.GP.CS.CMU.EDU's message of Tue, 23 Aug 88 10:37:55 EDT
What do you think about the possibility of putting (some/all/most) of the
sequence functions and also the iteration macros in the same category of
The category is that: any conforming implementation of the standard must provide
them. However, they are only available to programs that REQUIRE them. So, if you
want to use LOOP, you must say (require "LOOP"). If you want to use sequence
functions, you must say (require "SEQUENCE") or some such.
The reason is that it reduces the size of the mimimal image, but allows programs
to assume that the facilities are available if they're really needed.