[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Issue: STREAM-INFO (Version 6)
- To: Masinter.pa@Xerox.COM
- Subject: Issue: STREAM-INFO (Version 6)
- From: Kent M Pitman <KMP@STONY-BROOK.SCRC.Symbolics.COM>
- Date: Thu, 1 Dec 88 01:53 EST
- Cc: Dick@Wheaties.AI.MIT.EDU, CL-Cleanup@sail.stanford.edu
- In-reply-to: <881130-181526-3544@Xerox>
Date: 30 Nov 88 18:10 PST
We have not yet responded to RWK's comment, viz "Want less generic names.
eg, maybe STREAM-xxx".
What do you think about STREAM-LINE-WIDTH, STREAM-WRITE-SPACE, etc?
I don't really like the STREAM-xxx but can live with it as a compromise if it
will get this thing passed.
STREAM-LINE-WIDTH is ok with me.
STREAM-WRITE-SPACE seems redundant since WRITE is already a stream operation.
I guess I'd prefer just WRITE-SPACE.
LINE-POSITION could be STREAM-LINE-POSITION, conforming to the STREAM-xxx idea.
PRINTED-WIDTH is misleadingly named (in my opinion) because the function PRINT
is not involved. Since I think STREAM-WRITTEN-WIDTH looks a little weird,
I guess I'd like something like STREAM-STRING-WIDTH better.