[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Danny writes:

``I can't imagine them knowing anything else after they read the
documentation once.''

Names can cloud an explanation: If I named the FFT function
DELETE-ALL-FILES, one might allow the possibility of a user believing
something else after reading the documentation (even after reading it a
hundred times). Here :class is not such an offender, but the only reliable
impression from the name and explanation is that the slot is in the class
object - perhaps the class uses it for private information and the instances
cannot see it: that information would be conveyed by :shared.

Danny again:

``I answered your last question earlier -- referring to the use of dynamic
as an implementation tradeoff that is not relevant for shared slots.''

But the irrelevancy is not necessary.

Danny adds:

I don't think we need yet another programming language....  I would rather
use the symbol that specifies the option as our means of referring to the
type of slot, rather than another word that refers to a property of that
kind of slot.''

I suppose it's open for debate whether its type is a property of a thing,
but I agree that another programming language is bad idea.

Therefore, I simply believe that :shared is a better name than :class
in terms of being intuitive.