[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


re: Date: Thu, 13 Oct 88 15:25:59 MDT
    From: sandra%defun@cs.utah.edu (Sandra J Loosemore)
     I like the syntax suggested in what is described as "yet another proposal"
     but the way it specifies the optional parts is broken.  It should be
	#[size]H([type [rehash-size [rehash-threshold]]] (ki vi)*)
  It is very important that the syntax for expressing hash table options
  be extensible, and therefore keyword-based.  Any syntax like this that's
  positional, and furthermore assumes that all option values are
  non-lists, is simply not acceptable.  Putting the size out there in
  front is weird, too.

Is it really that important that the extensible part of the syntax look 
exactly like that for the "Standard" components?  Even in Sandra's format,
you still have room for implementation-specific keyword options.

-- JonL --