[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


    Date: Thu, 13 Oct 88 15:25:59 MDT
    From: sandra%defun@cs.utah.edu (Sandra J Loosemore)

    I like the syntax suggested in what is described as "yet another proposal"
    but the way it specifies the optional parts is broken.  It should be

    #[size]H([type [rehash-size [rehash-threshold]]] (ki vi)*)

It is very important that the syntax for expressing hash table options
be extensible, and therefore keyword-based.  Any syntax like this that's
positional, and furthermore assumes that all option values are
non-lists, is simply not acceptable.  Putting the size out there in
front is weird, too.

I still don't see why #. can't be used, but that's a minor point.