[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[no subject]

Named returns could improve readability a lot.

Using #f to mean both boolean False and no-value seems error-prone; so
does letting anything that's not #f mean #t.  I know, it's a
long-standing Lisp tradition, but then so is () == #f, which Dylan
does fix.

This comes up when some of the additional value returns are booleans
which are only sometimes valid.  If you test them before checking
whether they're valid, you get misleading results.  For that matter,
you can't even use type checking if you believe that they're always
valid, since all values are legitimate booleans.  If in some
unexpected case they turn out not to be valid, an error won't be

So why not make #f and #t the only valid booleans, and reserve #none
for "invalid"?