[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


EB raises at least one non-ridiculous point:  LOAD should provide a
'UNWINDING-SCOPE' or equivalent.  But I believe that EB's point is
that he believes this is common enough to want a macro to make it
easier to do and clearer that this is what is being done.  If you
don't agree, fine, but I don't think labeling it 'ridiculous' says
anything about why you don't agree or allows anyone to make any
judgment as to whether you are right, wrong, or biased.

Note that the LISPM has several macros to do similar types of things.
Consider LOGIN-SETQ and friends.

Let me go on record as saying I don't think the name relates to the
function at all, although I haven't got a better substitute.  I also
may actually agree with MOON (not that it's ridiculous, but that it
may not be common enough to be worthwhile).  I'd appreciate a bit
more justification.

I see I missed that you already thought they maybe should be named.
If LOAD does one, they WILL need to be named...