[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

debugger commands

What do people think about requiring debugger commands to be keywords instead
of simply symbols?  This would seem safer than the current situation (e.g.,
trying to see the value of your variable "q"...).

The only time I think *I* would mind having to type the extra symbol is when
moving with the "d" command-- and I think if backtraces had frame numbers
included, using "frame" would be just as easy (backtraces ought to include
frame numbers whatever the case)...

[Implementing this requires all of 13 characters to be changed!  {More if you
want to implement an "unknown command" message, which becomes reasonable with
this change}]


Miles Bader  --  HCRC, University of Edinburgh  --  miles@cogsci.ed.ac.uk
Nothing is sacred